Can we have a button to access this forum?


  • Can we have a button to access this forum? Somewhat non-intuitive to have to access via User menu (top right), then Resources - after which the screen shows various dictionary links ... but no link to the forum is apparent. You just have to somehow divine for yourself that scrolling sown will finally reach the forum posts.


  • @mistertoad That's actually something I asked for before. A clearly placed, clearly labeled 'access forum' button on all platforms that simply takes you straight to https://forum.lexulous.com/, at which point, you're in control of how you're logged in. Perhaps in the same place as the 'live', 'email', 'stats' options on the main game page. Would probably encourage more user interaction. I found the forum before there was a list of forum posts on the game site. Had some issues logging in with lex details so logged in with facebook for forum purposes which worked fine. The current implementation is a bit wonky. If I click on a forum post from the list underneath lobby, stats or email games (or under resources in your case), it will log me out of my main forum account and attempt to create a new one for my lex account. I therefore don't use the list on the lex site at all, I just access it from a bookmark or straight from address bar. That way I'm nicely logged in each time using the method I signed up with. BTW, the list of forum posts should be displayed underneath the game board (below lobby chat) as well as resources, unless you disabled that in settings.


  • @mistertoad I just click the top of the list of Forum posts below the game board, and it opens the Forum in a new tab. Tells me how many new posts/comments there are since my last visit, and I can read them or not as I wish. That's on a laptop. Idk if the same is possible on the app or a tablet.


  • @mapmakere Yes, I can see how it's pretty straightforward for most people assuming your lex and forum accounts are linked (not the case for me). Not a big issue for me anyway tbh. Would just be nice to get as many people using the forum as possible, and as easily as possible, that's all. I guess I could always try logging into lex using facebook which might solve my little issue.


  • @dan-mitchell
    Exactly - a "clearly labeled 'access forum' button" ... "to get as many people using the forum as possible".


  • @mistertoad I have just today noticed that there is a "plus" icon right below the lobby chat, next to the X icon that supposedly hides the list of forum posts. Not sure if this is a new feature or not... but it seems to take one directly to the Forums. Is this helpful?


  • @thatguythere202

    Thanks. Yes, you have made the point I have been trying to make clearly. The "plus" icon should be replaced with the word "Forum".

    The "plus" icon (+) is not a clear indication of anything at all. And a "cross" icon (x) does not have the opposite meaning to (+).

    If you click on (x) then access to the forum is LOST COMPLETELY, except by refreshing the browser!

    Really it needs sorting out, I think.


  • @Mistertoad Looks like they've added a clearer forum button. Good job. Gotta agree with you about the 'X' thing though. If I 'X' out of it, I lose access completely, even when refreshing. It only comes back if I visit settings and toggle 'show forum' back on. Slight overkill. How about a simple minus (−) and plus (+) to minimize and maximize it instead of nuking it entirely?


  • @dan-mitchell @lexulous Yes, good button. But it takes you to forum.lexulous.com/auth/lexcom with gets a 404 (does not exist) message. I imagine that will be fixed very soon, since the button is quite new.
    Since, as anyone should know, you can get to the forum by clicking on any one of the messages, the advantage of the button is that you should get to forum home page.
    I like the +/- expand contract solution, coupled with the setting to show/not show the forum that is relatively new.


  • @laysan I just clicked that button and it took me to https://forum.lexulous.com/


  • @thatguythere202 @lexulous Windows 10, Firefox. Just reloaded page, link on button is still ../auth/lexcom and gets to an error page... May be a cache issue? (Shouldn't be with a reload.) actually it is the https://forum.lexulous.com/2974/vote page, with a (Lexulous) message that "2974/vote" not found. Curious.


  • @laysan Working fine on Chrome. I think they're still figuring out a few quirks with Firefox.


  • @dan-mitchell @lexulous Yes, that is true re Firefox. But the "incorrect" link on the button is probably just what I used to call "an error between the keyboard and the chair." 🙂

    So maybe it is just my computer?? I just tried with Chrome and the button points to the same ../auth/lexcom link. I don't normally use Chrome, and I don't see, at first thought, how the two browsers are sharing something...
    If you just put the mouse pointer on the button and look at where it links (at the bottom of the browser page, as I am sure you know) you must get the correct forum.lexulous.com link...Right?

    And my spouse's computer (Win 10, desktop, Firefox) works exactly as mine does, i.e. the ../auth/lexcom link. So it is a bug somewhere along the line.


  • @laysan The https://forum.lexulous.com/auth/lexcom link on the button looks correct. It's just like that because it attempts to log you in to your username forum account in the process. My partner just tried on her account using Chrome and the end result it that it took her to https://forum.lexulous.com/ and logged her in at the same time. Try actually clicking the button in Chrome and it should work. The Firefox behavior you mentioned earlier shouldn't be happening but I assume they'll fix it.


  • @dan-mitchell @lexulous Thank you! Perhaps there has been a change made. However, during the previous discussions of the "failure" of the "Visit Forum" button, I was already logged into the forum. And I ended up on the "nonexistent "vote" page.
    After logging in and out (or refreshing) Lexulous, the game, the behavior was still the same, as I noted previously.
    However, after testing with my wife's computer again (and she is not a forum user) the link took her to a page asking if she wanted to register, etc.
    So I returned to my computer, logged out of the forum, and back to the game page. Clicked on the "Visit Forum" button and got to the forum home page. so with Firefox it works properly. When I tested Chrome, I was also logged into the forum, so that may have been the issue in both browsers, accessing the server.
    Thanks for your help in solving this! I have appreciates all your comments about the game for some time.


  • @laysan Right, so the auto-login link via the button didn't work initially because you were already logged into the forum? Possibly also because it was open in another tab? Glad you figured it out in the end anyway. Should be useful info for admins to make it work better i.e. letting you straight in regardless of whether you're already logged in or not. Think I'll continue using the 'type 'F' in address bar' method to access it lol. Chrome will autofill the address immediately and I'm already logged in. Even quicker than a bookmark for me.


  • We'll look into improving the login experience in case someone is already logged into the forum. Locking this topic for now.