Can we have a button to access this forum?

  • @Mistertoad Looks like they've added a clearer forum button. Good job. Gotta agree with you about the 'X' thing though. If I 'X' out of it, I lose access completely, even when refreshing. It only comes back if I visit settings and toggle 'show forum' back on. Slight overkill. How about a simple minus (−) and plus (+) to minimize and maximize it instead of nuking it entirely?

  • @dan-mitchell @lexulous Yes, good button. But it takes you to with gets a 404 (does not exist) message. I imagine that will be fixed very soon, since the button is quite new.
    Since, as anyone should know, you can get to the forum by clicking on any one of the messages, the advantage of the button is that you should get to forum home page.
    I like the +/- expand contract solution, coupled with the setting to show/not show the forum that is relatively new.

  • @laysan I just clicked that button and it took me to

  • @thatguythere202 @lexulous Windows 10, Firefox. Just reloaded page, link on button is still ../auth/lexcom and gets to an error page... May be a cache issue? (Shouldn't be with a reload.) actually it is the page, with a (Lexulous) message that "2974/vote" not found. Curious.

  • @laysan Working fine on Chrome. I think they're still figuring out a few quirks with Firefox.

  • @dan-mitchell @lexulous Yes, that is true re Firefox. But the "incorrect" link on the button is probably just what I used to call "an error between the keyboard and the chair." 🙂

    So maybe it is just my computer?? I just tried with Chrome and the button points to the same ../auth/lexcom link. I don't normally use Chrome, and I don't see, at first thought, how the two browsers are sharing something...
    If you just put the mouse pointer on the button and look at where it links (at the bottom of the browser page, as I am sure you know) you must get the correct link...Right?

    And my spouse's computer (Win 10, desktop, Firefox) works exactly as mine does, i.e. the ../auth/lexcom link. So it is a bug somewhere along the line.

  • @laysan The link on the button looks correct. It's just like that because it attempts to log you in to your username forum account in the process. My partner just tried on her account using Chrome and the end result it that it took her to and logged her in at the same time. Try actually clicking the button in Chrome and it should work. The Firefox behavior you mentioned earlier shouldn't be happening but I assume they'll fix it.

  • @dan-mitchell @lexulous Thank you! Perhaps there has been a change made. However, during the previous discussions of the "failure" of the "Visit Forum" button, I was already logged into the forum. And I ended up on the "nonexistent "vote" page.
    After logging in and out (or refreshing) Lexulous, the game, the behavior was still the same, as I noted previously.
    However, after testing with my wife's computer again (and she is not a forum user) the link took her to a page asking if she wanted to register, etc.
    So I returned to my computer, logged out of the forum, and back to the game page. Clicked on the "Visit Forum" button and got to the forum home page. so with Firefox it works properly. When I tested Chrome, I was also logged into the forum, so that may have been the issue in both browsers, accessing the server.
    Thanks for your help in solving this! I have appreciates all your comments about the game for some time.

  • @laysan Right, so the auto-login link via the button didn't work initially because you were already logged into the forum? Possibly also because it was open in another tab? Glad you figured it out in the end anyway. Should be useful info for admins to make it work better i.e. letting you straight in regardless of whether you're already logged in or not. Think I'll continue using the 'type 'F' in address bar' method to access it lol. Chrome will autofill the address immediately and I'm already logged in. Even quicker than a bookmark for me.

  • We'll look into improving the login experience in case someone is already logged into the forum. Locking this topic for now.