After hitting play for a multiplayer game, the screen goes blank

  • After hitting play for a multiplayer game, the screen goes blank and the site never comes back.

    This just started a few days ago. I have tried both safari and chrome on my mac with the same result. I can create a game or join a single-player game, but not a 4 player game.

    I am guessing that some new code was recently added to the client-side code that goes into a loop in the case of a multi-player game when run in some browsers.

  • @algor An additional observation is that after this happens, I can open another window into Lexulous and it does not complain about multiple connections, so hitting play on the multiplayer game must effectively kick me out of the site.

  • @algor Apologies for the inconvenience caused to you. Please send a screenshot to

  • @sakamvari A screen shot is this case would literally provide no information. Take it from a developer of software for over 30 years.

    However, the problem went away after a day for no apparent reason. Still, I heard other players experiencing the same problem today. It may afflict me again tomorrow.

    The intermittent nature also makes me suspect that the cause could be one of the random third party ads going haywire. Of course, Lexulous does not have much control over that.

  • @algor Please do share a screenshot as it would help us understand what else is on the page which might cause a problem. Other items on screenshot that help developers include screen dimensions, browser being used etc. etc.

  • @algor We have rectified the issue with a white board on multiplayer games. Please check once from your side.

  • @sakamvari,

    The problem has continued to happen to me and others the past 3 days.

    Note, the problem is NOT a white board, but rather that when a player attempts to join a 4 person game that was created before the player logged in, an error happens that logs the player out, resulting in a largely empty screen. There is no board, because the player never joined and the host had no opportunity to accept the player.

    I am under the impression that Pat30 sent in a video of this happening several days ago.

    Note that there is a workaround. The player can log back in and ask the host to delete and recreate the 4 person game while all the players are logged in. Then everybody can join.